Составте алгоритм нахождения наименьшего из трех значений. ееееееееее!

Составте алгоритм нахождения наименьшего из трех значений.Помогитеееееееееее!

    Успехов!

     

     

           x = Min(x,A(ц));

    КонецЦикла;

              Возврат(а);

         КонецЕсли;

     

        Если a<b Тогда

  • Допустим, в языке есть встроенная функция

     

    Функция Min(a,b)

              Возврат(b);

     

  • Min(a,b) которая определяет мин из двух значений. Тогда алгоритм выглядит так

     

    Вот и всЁ! Учитесь мыслить алгоритмически структурно, разбивая сложный алгоритм на ряд простых и понятных, и всё будет очень просто.

    А если нужно найти мин из N чисел, которые запрятаны в массив А(n), то так

    КонецФункции

    x=999999999999999999999; // какое-то ОЧЕНЬ большое число

     

    Для ц=1 по N цикл

     

    А что, если такой функции в языке нет, спросишь ты, тогда её нужно написать самому, например, так

        Иначе

    x=Min(x,c); 

    х=Мin(a,b);