Составить программу: Дана буква русского алфавита. Вывести на экран является ли эта буква гласной, согласной или разделительным знаком

Составить программу: Дана буква русского алфавита. Вывести на экран является ли эта буква гласной, согласной или разделительным знаком

    КонецЕсли;  

      // текст основной программы

    Так как не указан язык программирования, в котором нужно реализовать текст, напишу на некоем псевдоязыке, текст которого легко переводится на известный тебе язык.

    знак(1)=".";

    согласная(2)="б";

      Вот собственно и всё.  

    Если язык требует при объявлении массива его размерность- её нужно указать. многие языки имеют встроенную функцию определения размерности, некоторые языки имеют встроенные функции поиска в массиве, тогда нужно воспользоваться ими, а не писать свои функции.

     Возврат(0);

    согласная(4)="в";

     

  • Так как понятие "гласная", "согласная" и пр. не являются формализованными понятиями, то есть их нельзя вычислить алгоритмически, их нужно задавать таблично, константами, а так как их много, то лучше всего подойдут массивы.

    // объявления массивов

    гласная(4)="е";

     ............................

    ИначеЕсли  фСогласная(буква)=1

    Основная программа, как правило тоже обрамляется циклом с выходом по условию, которое либо системное либо некий хитрый символ(или клавиша), который ты определяешь концом ввода данных.

    гласная(), согласная(), знак()

    функция фСогласная(буква)  

    Иначе        Сообщить(буква+" не квалифицирована");

     Сообщить(буква+" разделительный знак");

    Почему-то при записи убежал возврат каретки, попробовал восстановить. :)

    // заполнение массивов

                 Возврат(1);  

    Если фГласная(буква) = 1 тогда

    Замечание4

    Если ИначеЕсли... как правило реализуется операторами Case

    Успехов!  

    гласная(3)="Е";

        

  •  

    функция фзнак(буква)  

    ................

    знак(4)="?";

     ............................

    знак(2)=".",;

    КонецФункции  

    Ввод(буква);

     ............ // Функции

     

    ..........................

    Замечание3

    Замечание1

    гласная(1)="А";

    гласная(2)="а";

    Вместо массив можно использовать строки, содержащие подряд буквы, например, гласная="АаЕеИи....". в этом случае для поиска нужно пользоваться соответствующими встроенными строковыми функциями.

    В общем, программа будет такой

    согласная(1)="Б";

     

      В общем, смысл должен быть тебе понятен, а дальше - творчество.

    Замечание2

         Если буква=гласная(ц) тогда

       Сообщить(буква+" гласная");  

         КонецЦикла;  

    КонецФункции

    ..........................

     КонецЦикла;  

    знак(3)="!";

    КонецФункции  

     Для ц=1 по кг Цикл  

    функция фГласная(буква)  

    тогда             Сообщить(буква+" согласная");  

    ИначеЕсли фЗнак(буква)=1 тогда      

    согласная(3)="В";