Охарактеризуйте исполнителя Чертёжник

Охарактеризуйте исполнителя Чертёжник

    Исполнитель Робот умеет перемещаться по лабиринту, начерченному
    на плоскости, разбитой на клетки. Между соседними (по сторонам)
    клетками может стоять стена, через которую Робот пройти не может.
    У Робота есть восемь команд. Четыре команды – это команды-приказы:
    вверх вниз влево вправо
    При выполнении любой из этих команд Робот перемещается на одну клетку
    соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Если Робот получит
    команду передвижения через стену, то он разрушится.
    Ещё четыре команды – это команды проверки условий. Эти команды
    проверяют, свободен ли путь для Робота в каждом из четырёх возможных
    направлений:
    сверху свободно снизу свободно слева свободно справа свободно
    Эти команды можно использовать вместе с условием «eсли», имеющим
    следующий вид:
    если условие то
    последовательность команд
    все
    Здесь условие – одна из команд проверки условия.
    Последовательность команд – это одна или несколько любых команд-
    приказов.
    Например, для передвижения на одну клетку вправо, если справа нет стенки,
    можно использовать такой алгоритм:
    если справа свободно то
    вправо
    все
    В одном условии можно использовать несколько команд проверки условий,
    применяя логические связки и, или, не, например:
    если (справа свободно) и (не снизу свободно) то
    вправо
    все
    Для повторения последовательности команд можно использовать цикл
    «пока», имеющий следующий вид:
    нц пока условие
    последовательность команд
    кц
    Например, для движения вправо, пока это возможно, можно использовать
    следующий алгоритм:
    нц пока справа свободно
    вправо
    кц

  • Незнаю как првильно даже ответить, может так(вмосто робота чертёжник):

    Также у Робота есть команда закрасить, при которой закрашивается клетка,
    в которой Робот находится в настоящий момент.