Определить, что будет напечатано в результате работы след программы. Алгоритм яз :АлгНач цел b , c b := 0 c := 0 нц пока b 10 c := c + b b :=

Определить, что будет напечатано в результате работы след программы .

Алгоритм яз :

Алг

Нач

  цел b , c 

  b := 0

  c := 0

  нц пока b <> 10 

  c := c + b

  b := b + 1 

кц

вывод c 

желательно с обьяснением

    Все эти строки посвящены тому, чтобы просто присвоить b и с по 0.

    Так... пока b<>10 программа суммирует заданное значение B, а потом увеличивает b на 1, и так десять раз.

    Все знают ,что это озночает.

     

    Дальше:

    Смотрим на :

    Разберемся, что сдесь происходит:

  • С = 45
    Это цикл, который будет повторяться пока b не равно 10, как только b = 10 выводится значение переменной с
  •  Разберем все по  порядку...

    нц пока b <> 10 
    c := c + b
    b := b + 1

    вывод c 

    Ответ: на экран будет выведено : 45

  • Алг
    Нач
    цел b , c 
    b := 0
    c := 0

    тоесть с будет изменяться:

    Я лично разобрался в этих странных буковках ,зная язык програмирования - Pascal.

    Очевидно, что это цикл (While), кц - окончание цикла.

    0, 1, 3,6,10,15,21,28,36,45 - это окнечный результат, потому что когда b=9, и ему присваивают: b:=9+1=10 цикл - окончивается. Итого, в результате цикла,с=45.

    Дальш

    кц